This project has moved and is read-only. For the latest updates, please go here.

Compile error for native wrapper

Jun 23, 2011 at 11:32 AM

I tired to compile ACMLWrapper project. but compile was incomplete with two MSB8012 warning. and compiled dll not works.

I installed ACML fortran library for window 32bit with default path. and set ACMLWarpper's configuration to 32bit. I used VS2010.

how to compile ACMLWarpper complete?

Jun 23, 2011 at 11:38 AM

>. but compile was incomplete with two MSB8012 warning. 

I believe you can ignore these.

> compiled dll not works.

Did it did produce a DLL? If so, what is the error you are getting? Did you copy the ACML DLLs to the same directory as the wrapper DLL when you tried to test it?


Jun 23, 2011 at 11:50 AM

I copy MathNET.Numerics.ACML.dll to same folder in MathNET.Numerics.dll. also libacml_mp_dll.dll, libifcoremd.dll, libiomp5md.dll, libmmd.dll too.

and I see "Unable to load DLL 'MathNET.Numerics.ACML.dll'" error.

Jun 23, 2011 at 11:58 AM

and i get MathNet.Nermerics.ACML.dll from \src\NativeWrappers\Windows\Release. not \src\NativeWrappers\Windows\Win32\Release.

Jun 23, 2011 at 2:58 PM
Edited Jun 23, 2011 at 2:59 PM

I just tried a fresh install. The wrapper built and all the unit tests passed. I'm not sure what the problem could be.

Are you testing on a 32bit or 64bit machine?

Jun 23, 2011 at 4:27 PM

I tested on both 32bit and 64bit machine. On 32bit machine, "Unable to load DLL 'MathNET.Numerics.ACML.dll'" error occured. and on 64bit machine, "BadImageFormatException was unhandled" error occured.

I make the folder to contain MathNET.Numerics.ACML.dll, MathNet.Numerics.dll,, and other ACML dlls. and add MathNet.Numerics.dll to my test project references. Do I made ​​a mistake?

Jun 23, 2011 at 4:32 PM

There are multiple versions of the ACML:

I had some trouble with the PGI versions before whereas Intel Fortran worked fine. Can you double check which libraries you used?


Jun 23, 2011 at 5:47 PM
Edited Jun 24, 2011 at 4:14 AM

Here is the bundle I tested: xxxxx

Try running the unit tests in ACMLWrapperTests.dll. Any luck?

Jun 24, 2011 at 2:12 AM

It works perfectly. I missed set my project build option to 64bit. :) now, I fixed all projects, library's setting to 64bit, Math.Net numeric with native provider works perfectly. Thanks cuda, jvangael.